Hello Friend,

If this is your first visit to SoSuave, I would advise you to START HERE.

It will be the most efficient use of your time.

And you will learn everything you need to know to become a huge success with women.

Thank you for visiting and have a great day!

Arch forums is a 'sewer'

backseatjuan

Master Don Juan
Joined
Nov 2, 2011
Messages
4,198
Reaction score
1,359
Age
39
Location
Россия
Speaking of 50 year old virgins living with parents in the basemen mom bathroom. I posted a simple question is newbie corner, what package do I need to install in order to have a library libqtdbus. What followed was a vomit of questions, how did you install arch, what repos are you using, etc, etc.. Tell me something, if let's say there is a program A which requires a library B, does it makes any difference on what OS you are trying to run it? Let's say if you try to run it on Debian, would it still not require library B? That's stupid. If you want to see inceldom go to arch forums, hit the newbie corner. Idea there is not to provide help, but to rant and btch and get empowerment from that.

Can anybody make this run? https://www.parom.tv/en/linux

Library in question is libQtDBus

There must be a package that provides it, somewhere, I wonder what the name of that package is.
 

mozarto.o

Don Juan
Joined
May 16, 2020
Messages
54
Reaction score
47
Age
30
Tell me something, if let's say there is a program A which requires a library B, does it makes any difference on what OS you are trying to run it? Let's say if you try to run it on Debian, would it still not require library B?
The incels are right to vomit on you, not all libraries are called the same across all unix systems.
You can also try and run an equivalent of alien for Arch with the .deb package.
 

backseatjuan

Master Don Juan
Joined
Nov 2, 2011
Messages
4,198
Reaction score
1,359
Age
39
Location
Россия
If program requires libAtDBus then there must be that library present it's that simple. I can't help if you are retarded and don't understand it. But it is true, when it is compiled, it's reference table requires that library, and when a function from that library is called, it will look for that file, libQtDBus, and not any other file like you suggest. So, it becomes a simple matter here, there must be installed a package that contains this damn library.

Or am I wrong here?

No I'm not. Thus you must be retarded to ask these questions.

How did you install Arch?
What repos are you using?
What are you trying to do?
Is it an AUR program?
and a bunch of other retarded questions..

All those questions are aimed towards telling me to go and figure it out myself, none of it is aimed towards helping me out. Why? I know that the package name is libqtdbus4 in Debian, all I need to know is what it is named in Arch.

It is just like you half assed reply. It's not aimed to help, it is aimed towards boosting your self ego online, because you live with your mom, have no girlfriend, masturbating to p0rn, no car, no job, no life.


And I must add, those forums, if you read messages, it's same sht all over in every message. There was this one guy who asked how to change cpu governor to performance and keep it that way. It's a simple answer, install CoreCtrl, they went on 20 messages doing same sht you doing. That's beyond virgin and no life, it's more towards gay.
 
Last edited:

Morpheus

Don Juan
Joined
Jan 28, 2015
Messages
29
Reaction score
8
I've never actually posted a question to the Arch forums. I usually don't need to. As you noted, they are so thorough and like to get to be bottom of things, which is perhaps why they are so informative. They do have quite a reputation for this as well as their superiority so I guess you only have your self to blame.

I didn't seem to have any difficulty installing the AUR package you seem to have already found:

Code:
[morpheus@T1600 ~]$ yay -S paromtv-appimage
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur: 1]  paromtv-appimage-1.1.3-1

:: Downloaded PKGBUILD (1/1): paromtv-appimage
  1 paromtv-appimage                         (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> n
:: Parsing SRCINFO (1/1): paromtv-appimage
==> Making package: paromtv-appimage 1.1.3-1 (Sun Aug  2 13:56:19 2020)
==> Retrieving sources...
  -> Downloading Parom.TV.AppImage...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 61.4M  100 61.4M    0     0  1595k      0  0:00:39  0:00:39 --:--:-- 2463k
  -> Found paromplayer.desktop
  -> Found paromplayer.png
==> Validating source files with sha256sums...
    Parom.TV.AppImage ... Passed
    paromplayer.desktop ... Passed
    paromplayer.png ... Passed
==> Making package: paromtv-appimage 1.1.3-1 (Sun Aug  2 13:57:00 2020)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found Parom.TV.AppImage
  -> Found paromplayer.desktop
  -> Found paromplayer.png
==> Validating source files with sha256sums...
    Parom.TV.AppImage ... Passed
    paromplayer.desktop ... Passed
    paromplayer.png ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
==> Sources are ready.
==> Making package: paromtv-appimage 1.1.3-1 (Sun Aug  2 13:57:02 2020)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Entering fakeroot environment...
==> Starting package()...
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "paromtv-appimage"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: paromtv-appimage 1.1.3-1 (Sun Aug  2 13:57:04 2020)
==> Cleaning up...
[sudo] password for morpheus:
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) paromtv-appimage-1.1.3-1

Total Installed Size:  61.49 MiB

:: Proceed with installation? [Y/n]
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
:: Processing package changes...
(1/1) installing paromtv-appimage                  [######################] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Updating the desktop file MIME type cache...

For comparing packages and libraries across distributions, I recently found this exceedingly useful website [repology.org]. In their list of repositories, the AUR seems to be the largest, so you were right [in your other thread]. It isn't entirely obvious how it is organised but to search for packages, you seem to have to go to the Projects tab. However, libqtdbus didn't seem to turn up much.

Anyway, you do seem better informed than me as to what the underlying problem is. Good luck!
 
Last edited:

image

"If you love women, you must read the SoSuave Guide to Women. It's fantastic!"

Morpheus

Don Juan
Joined
Jan 28, 2015
Messages
29
Reaction score
8
AUR is outdated for that package. Even if you install it, it won't work. The new program version requires those libraries.
That's interesting because it wasn't very dated (last time, this year?). The application did just seem to play very nice muzak but I didn't know whether the problem was somehow my location or not. Arch is usually comparatively fast but it does all depend. That's one reason, I'm slowly moving to Guix. The packages I use are increasingly produced by people on Guix.

If you have to install a .deb on Arch the following might be helpful:
[unix.stackexchange.com]
[www.maketecheasier.com]

I unsuccessfully attempted this once, but is was a tricky package which is now in the AUR.
 

backseatjuan

Master Don Juan
Joined
Nov 2, 2011
Messages
4,198
Reaction score
1,359
Age
39
Location
Россия
Yea, when you launch the player it plays a video saying that you need to update. I did find the package that provides that library, it is called

qt4

All they had to do is type install qt4 man, instead of all those pointless questions. You build qt4 from AUR and it provides that library.
 
Top